Status
Get in touch
Back
Maintenance
Server maintenance
Completed 2 Jul at 05:00pm BST.
Affected services
App
API
Completed
Posted 2 Jul at 05:00pm BST.
Started
We will be performing a server infrastructure upgrade.
Posted 2 Jul at 03:00pm BST.